Known

Solo6010 driver on ubuntu 15.10 throws error on installation

Michael Klevitsky shared this problem 1 year ago

Trying to install the solo drivers for my 4 port card [BC-04120A 4 port MPEG4 video encoder / decoder] on a new ubuntu 15.10 desktop, after old system failure. Initially seem to install using release package: http://downloads.bluecherrydvr.com/solo6x10/solo6010-dkms_2.4.11_all.deb, but with the attached error text, and vertical sync was an issue on all inputs. A system update was done. After this, I cannot get the driver to load at all and cannot connect to any inputs, dmesg has no reference to solo6x10. Attached is lspci screenshot showing detection of the card.

I last attempted to install from source after removing the dkms package, drivers appeared to install without error, though no initialization occurs, no mention of the card in dmesg output.

Still looking through my backups for my server key to complete installation of the server components, but want to get this going first.

Any suggestions?

Thanks,

Michael

Comments (5)

photo
1

Please download this and try to install it:

http://lizard.bluecherry.net/~autkin/solo6010-dkms_2.4.12_all__conflict_declared.deb

It should propose you to downgrade kernel version, it is normal.

If it doesn't work for you, you could alternatively try the version of driver from kernel upstream, in order to do so, install our kernel packages from here: http://lizard.bluecherry.net/~autkin/kernel_releases/release/tw5864_stable/1.3-0-g88e05cb/ (all 4 packages).

Please let us know how it goes. Sorry for this issue.

photo
1

Andrey,

I tried to install the deb file [2.4.12_all__conflict_declared.deb], I was not prompted to downgrade the kernel version. This install failed, so I went to install upstream. After reboot, experienced a kernel panic.

I am back to new re-installation of 15.10 and unable to install the driver without error. This is the fault message from last software installation attempt:

  1. (Reading database ... 100%

    (Reading database ... 208254 files and directories currently installed.)

    Preparing to unpack .../solo6010-dkms_2.4.12_all__conflict_declared.deb ...

    Removing all [solo6010-2.4.12] DKMS Modules

    Done.

    Unpacking solo6010-dkms (2.4.12) over (2.4.12) ...

    Setting up solo6010-dkms (2.4.12) ...

    Removing all [solo6010-2.4.12] DKMS Modules

    Error! There are no instances of module: solo6010

    2.4.12 located in the DKMS tree.

    Done.

    Adding [solo6010-2.4.12] Module to DKMS build system

    Doing initial module build

    Error! Bad return status for module build on kernel: 4.2.0-22-generic (x86_64)

    Consult /var/lib/dkms/solo6010/2.4.12/build/make.log for more information.

    dpkg: error processing package solo6010-dkms (--install):

    subprocess installed post-installation script returned error exit status 10

After the install attempt of the driver, I installed mplayer2 for testing and the attached crash report was generated from dkms module build and following terminal output:

  1. [mplayer2 install text ] ...
  2. Unpacking mplayer2 (2.0-728-g2c378c7-4build1) ...

    Processing triggers for man-db (2.7.4-1) ...

    Processing triggers for mime-support (3.58ubuntu1) ...

    Setting up solo6010-dkms (2.4.12) ...

    Removing all [solo6010-2.4.12] DKMS Modules

    Done.

    Adding [solo6010-2.4.12] Module to DKMS build system

    Doing initial module build

    ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/solo6010-dkms.0.crash'

    Error! Bad return status for module build on kernel: 4.2.0-22-generic (x86_64)

    Consult /var/lib/dkms/solo6010/2.4.12/build/make.log for more information.

    dpkg: error processing package solo6010-dkms (--configure):

    subprocess installed post-installation script returned error exit status 10

    Setting up libgif4:amd64 (4.1.6-11) ...

    Setting up libavresample-ffmpeg2:amd64 (7:2.7.3-0ubuntu0.15.10.1) ...

    Setting up libpostproc-ffmpeg53:amd64 (7:2.7.3-0ubuntu0.15.10.1) ...

    Setting up libsdl1.2debian:amd64 (1.2.15-11ubuntu1) ...

    Setting up mplayer2 (2.0-728-g2c378c7-4build1) ...

    Processing triggers for libc-bin (2.21-0ubuntu4) ...

    Errors were encountered while processing:

    solo6010-dkms

    E: Sub-process /usr/bin/dpkg returned an error code (1)

port/channel testing with mplayer is back to vertical sync loss on all channels from the Bluecherry card. Testing of an IP camera shows proper video with mplayer.

I spoke with the new computer hardware folks today, the processor is a new 6th gen I5 Intel processor on a Gigabyte motherboard, new features are supported by the new 4.2 kernel only. Will it be possible to run the older capture card and driver?

Thanks,

Michael

photo
1

It is pity that our booting our latest kernel resulted in panic. As I understand you have reinstalled the system from scratch since then, and cannot boot it again. But if you can, a shot of screen with kernel panic info would be of great value for us.

To get able to install dkms package, you would need to downgrade your linux-headers and linux-image packages manually. To do so, please check available versions with "apt-cache search linux-headers", "apt-cache search linux-image", and do "apt-get install ..." those which have versions not higher than 3.16.

There is, however, another very promising way, which would require you to wait at last several days, while we'll work on new better packaging for the driver. Are you fine to wait?

photo
photo
1

Hi Andrey,

I investigated possibility to downgrade the kernel... unfortunately, this breaks many things in my new system. I have begun using the system for other purposes and don't want to risk losing my work.

I can wait for an update to the driver. For information, my new kernel is 4.2.0-22-generic.

Thanks,

Michael

photo
1

Hi,

4.2.0 kernel is recent enough, you can try to go with solo6x10 driver module which is shipped by linux-image-extra package.

We recommend you to use latest unstable package, which has support for such driver.

Please let us know how it goes.