Known

Client 2.2.4 - Consistent crashes when browsing events if prior event is not fully downloaded.

Jason Sauders shared this problem 6 months ago

Hi friends. I'm having a problem that seems very easy to reproduce. Some background info:

Server = Ubuntu Server 14.04, Bluecherry 2.6.2

Client 1 = Macbook Pro w/ Ubuntu 16.04, Bluecherry Client 2.2.4

Client 2 = ASUS Laptop w/ Ubuntu 16.04, Bluecherry Client 2.2.4

(both client systems are exhibiting the same issue with the same frequency)

All cameras record 24/7

I was able to exhibit the same crashing behavior with client 2.2.4 on Windows 8 as well.

Beginning with client 2.2.4, a feature was introduced to begin playing a video before it's fully downloaded. On average it seems once I hit "Downloading: 20%" or so, I'll begin to see the video feed. This is an awesome feature, absolutely love it, however I'm noticing if I double click another video feed *before* the prior feed has fully downloaded, it'll often instigate a crash of the client.

I did a little test earlier by cycling through ~30 prior event feeds. In every instance, I let it fully download before clicking on the next one. I had no crashes. Everything worked great.

At the same token, I went to repeat that same process but would intentionally double click the next feed before the prior was fully downloaded. On the very first try, the client crashed. It doesn't always crash on the very first clip while the prior is downloading. I've been able to get to the 4th or 5th consecutive clip before the crash happens. Either way, it's a matter of a few clicks to instigate the crash.

Relevant syslog snip of that particular crash:

Sep 25 14:51:19 JSMB01 kernel: [14760.183609] bluecherry-clie[12483]: segfault at 18 ip 00000000004ef694 sp 00007ffcc136e170 error 4 in bluecherry-client[400000+22c000]

Sep 25 14:51:38 JSMB01 kernel: [14778.302075] bluecherry-clie[13083]: segfault at 18 ip 00000000004ef694 sp 00007ffdaf9a9830 error 4 in bluecherry-client[400000+22c000]

I replicated the setup again with a screencast program running. Here's a quick video clip showing it:

https://drive.google.com/open?id=0B96Ld5Ukgbx8TUk0bFNUa2k2RVE

Comments (2)

photo
1

Hi Jason,

thank you for providing steps to reproduce crash,

fix will be available in the next client release

photo
1

Hey there, Anton. As you know I've been testing the 2.2.5 client lately. I'm not sure if it was luck, a positive fluke at the time, or what, but I'm finding that I can quite consistently crash the client while duplicating the above steps as before. In the most recent circumstance, I was cycling through feeds and only clicking on the next feed after the current one began playing the beginning part, whereas before I was just mashing next, next, next, next, etc. in an effort to instigate the crash. Even still, I'm hitting the same issue as before.

In short, this time I was simply doing:

1) Double click feed to play

2) Once feed appears (around the 30%-ish download mark), double click the next feed

3) After double clicking the next feed, wait for it to begin playback (again, around the 30%-ish download mark), and then double click the next feed

There are instances where I feel as though I can go through many feeds without issue doing the above. Other times, I feel like I run into a Bluecherry client crash quite easily after only a few clicks.

Sorry about the news. If there's anything I can do to help test anything beyond 2.2.5, please let me know. I'd be happy to take a look.

As it stands now, the only way I can reliably cycle through many many feeds during playback is to wait for the entirety of the feed to download before clicking on the next feed. Despite the speed of my new router, some of my 24/7 recordings are quite large (nearly 1 GB for a single 15 minute section), so this can take some time to fully transfer. Unfortunately it's the only way I can be confident that the client won't crash on me.

A relevant portion of 'dmesg' following my most recent crash if it helps (again on 2.2.5, Ubuntu):

[ 1662.395256] bluecherry-clie[5779]: segfault at 18 ip 00000000004efb04 sp 00007fff142c47e0 error 4 in bluecherry-client[400000+22c000]

[ 1689.351328] applesmc: send_byte(0x00, 0x0300) fail: 0x40

[ 1689.351331] applesmc: FS! : write data fail

[ 1689.788184] bluecherry-clie[5972]: segfault at 18 ip 00000000004efb04 sp 00007ffced0f8420 error 4 in bluecherry-client[400000+22c000]

Thank you again for your time and assistance!