Need Answer

cant change location in Mange storage section

pradnyesh naik shared this question 6 months ago

Hello Support!

We have bought 16 port license from blue cherry.

We have installed server from Server iso available for download on

your website.

We are now facing issue while changing default storage location in

our bluecherry server.

Whneever I try to change the path it pops up error and ask to

perform " Mkdir -p /my_location/ and then chown to

bluecherry:bluecherry"

My storage is Software RAID5 volume and very much accessible with all correct permissions

even after performing these commands successfully I am not able to

add the storage location and keep getting same error

Kindly support on this issue!

Comments (1)

photo
1

I got the same error. It seems to be that the UI is being served from apache running as www-data. This user does not have read access to anything restricted to the bluecherry user. It appears to be a bug in the popup hint

I was able to get around this by adding www-data to the group that owns the directory

I then rebooted the vm just to make sure the new group setting took effect, I could probably have restarted the bluecherry service though.

  1. vagrant@bluecherry:~$ sudo -u www-data ls /media/sf_bluecherry-data/
  2. recordings
  3. vagrant@bluecherry:~$ sudo gpasswd -d www-data vboxsf
  4. [sudo] password for vagrant:
  5. Removing user www-data from group vboxsf
  6. vagrant@bluecherry:~$ sudo -u www-data ls /media/sf_bluecherry-data/
  7. ls: cannot open directory /media/sf_bluecherry-data/: Permission denied